Please be advised that the maintenance event scheduled for today has been postponed and will be rescheduled.
This decision is a direct result of the recent utility power incident in the us-east4 region. Our priority is to ensure the stability of the platform, and proceeding with maintenance during this time is not advisable.
We sincerely apologize for any inconvenience this change may cause. We will notify you with the new maintenance date and time as soon as the schedule is finalized.
Thank you for your understanding.
Posted Oct 15, 2025 - 13:05 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 15, 2025 - 12:00 UTC
Scheduled
The IBM Power for Google Cloud operations team will perform essential maintenance on the Power Compute Control Plane.
No impact to existing Virtual Machine Instances is expected.
During the maintenance window Virtual Machines Instances will remain operational, but they will not be viewable or modifiable in the IBM Power for Google Cloud Web Console, pcloud CLI, or API. Additionally, customers will not be able to provision new Virtual Machine Instances until the maintenance is completed.
Posted Sep 30, 2025 - 19:49 UTC
This scheduled maintenance affected: US-East4 (Ashburn, Northern Virginia, USA) (API).