Please be advised that the ongoing maintenance activity requires additional two-hour extension to ensure all tasks are completed thoroughly.
We understand that this extension may cause inconvenience, and we deeply apologize for any disruption this may cause. Our team is working diligently to finalize the remaining tasks as quickly and efficiently as possible.
We will continue to provide updates as needed. Thank you for your patience and understanding.
Posted Nov 12, 2025 - 23:30 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 12:00 UTC
Scheduled
The IBM Power for Google Cloud operations team will perform essential maintenance on the Power Compute Control Plane.
No impact to existing Virtual Machine Instances is expected.
During the maintenance window Virtual Machines Instances will remain operational, but they will not be viewable or modifiable in the IBM Power for Google Cloud Web Console, pcloud CLI, or API. Additionally, customers will not be able to provision new Virtual Machine Instances until the maintenance is completed.
Posted Oct 29, 2025 - 20:55 UTC
This scheduled maintenance affected: US-East4 (Ashburn, Northern Virginia, USA) (API, Power Compute).