Power Compute Host Control Plane Maintenance

Incident Report for IBM Power for Google Cloud

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 01:09 UTC

Update

Engineering team is still working diligently to complete the change. We understand that this extension may cause inconvenience, and we deeply apologize for any disruption this may cause.
We will provide an update in 60 minutes.
Posted Nov 13, 2025 - 23:41 UTC

Identified

After completing our scheduled maintenance https://status.gcp.converge.cloud/incidents/413z7bbqhy72, engineering identified an additional change that we're proactively addressing. We don't anticipate any service impact and will share an update once the work is complete. Next notice will be sent in 90 minutes.
Posted Nov 13, 2025 - 22:11 UTC
This incident affected: US-East4 (Ashburn, Northern Virginia, USA) (Power Compute).