Utility power preventative maintenance in us-east4

Incident Report for IBM Power for Google Cloud

Resolved

The preventative maintenance in the us-east4 had been completed.
Posted Oct 17, 2025 - 02:46 UTC

Investigating

Please be advised that our data center facility provider has scheduled utility power preventative maintenance in the us-east4 region today thursday from 14:30 EST to 21:00

During the maintenance, electric loads will be seamlessly transferred to generator power.

No customer impact is expected.

We will continue to update this issue regarding the power preventative maintenance until fully resolved.
Posted Oct 16, 2025 - 17:58 UTC
This incident affected: US-East4 (Ashburn, Northern Virginia, USA) (API, Power Compute, Network Fabric, Block Storage).